Projet

Général

Profil

Anomalie #6888

dynacase-http-api-v1 requiet dynacase-core >= 3.2.22

Ajouté par Jérôme Augé il y a plus de 2 ans. Mis à jour il y a plus d'un an.

Statut:
Rejeté
Priorité:
Normal
Assigné à:
Version cible:
Début:
18/11/2016
Echéance:
% réalisé:

100%

Version source:
Solution proposée:
Principaux fichiers impactés:
Complexité:
Contrôle:
Régression:
Non
Jalons: 3.2 R17

Description

J'ai installé dynacase-httpapi-v1 1.0.2-1 avec dynacase-core 3.2.21, et j'ai l'erreur suivante lorsque j'accède à l'API :

{"success":false,"messages":[{"type":"error","contentText":"1, Call to undefined method Dcp\\HttpApi\\V1\\AuthenticatorManager::getAuthType(), \/var\/www\/c3\/HTTPAPI_V1\/ContextManager.php, 13"}],"data":null}

Suite au refactor de AuthenticatorManager fait sur dynacase-core 3.2.22, il faut monter la dépendance de dynacase-httpapi-v1 pour requérir dynacase-core >= 3.2.22 et non dynacase-core >= 3.2.18.

Historique

#1 Mis à jour par Éric Brison il y a plus d'un an

  • Version cible mis à 1.0.3
  • Assigné à mis à Jérôme Augé

#2 Mis à jour par Jérôme Augé il y a plus d'un an

Corrigé par #6900

#3 Mis à jour par Jérôme Augé il y a plus d'un an

  • % réalisé changé de 0 à 100

#4 Mis à jour par Jérôme Augé il y a plus d'un an

  • Statut changé de Nouveau à Rejeté

Formats disponibles : Atom PDF