Projet

Général

Profil

Amélioration #6509

[Stubs/Class/Param/Wdoc] Les stubs indiquent les param comme étant des constantes, core ne le fait pas

Ajouté par Charles Bonnissent il y a presque 3 ans. Mis à jour il y a plus de 2 ans.

Statut:
Rejeté
Priorité:
Normal
Assigné à:
Version cible:
Début:
15/07/2016
Echéance:
% réalisé:

0%

Version source:
Solution proposée:

Ajouter les PARAM dans les constantes de classes générés par CORE

Principaux fichiers impactés:
Wiki Détail:
Contrôle:
Jalons: 3.2 R17

Description

Dans le code des familles générés par core les param ne sont pas inclus alors que dans les stubs ils le sont.

Du coup, si dans les sources, on utilise les constantes lorsque l'on importe le fichier on a une erreur cryptique pour le commun des mortels (voir en PJ).

Clipboard (65,2 ko) Charles Bonnissent, 15/07/2016 17:19

Historique

#1 Mis à jour par Marc Claverie il y a presque 3 ans

  • Version cible mis à 3.2.23
  • Tracker changé de Anomalie à Amélioration
  • Statut changé de Nouveau à Assigné
  • Assigné à mis à Éric Brison

#2 Mis à jour par Éric Brison il y a presque 3 ans

Les familles , les constantes de paramétres de familles sont bien générées dans le fichier FDLGEN.Class.Attrxxx.php générés.

Préciser le cas de reproduction.

#3 Mis à jour par Éric Brison il y a presque 3 ans

  • Statut changé de Assigné à À analyser
  • Assigné à changé de Éric Brison à Charles Bonnissent

#4 Mis à jour par Éric Brison il y a plus de 2 ans

Je pense que le problème provient du fait que la famille du workflow n'est pas encore généré au moment de l'importation de la famille.

#5 Mis à jour par Éric Brison il y a plus de 2 ans

  • Statut changé de À analyser à Rejeté

Formats disponibles : Atom PDF