Projet

Général

Profil

Anomalie #6444

Class \Dcp\Mail\Message et version erroné de Dynacase Platform dans champs "X-Mailer:"

Ajouté par Jérôme Augé il y a presque 3 ans. Mis à jour il y a presque 3 ans.

Statut:
Intégré
Priorité:
Normal
Assigné à:
Version cible:
Début:
09/06/2016
Echéance:
% réalisé:

100%

Version source:
Solution proposée:
Principaux fichiers impactés:
Complexité:
Contrôle:
Thème:
Socle technique
Régression:
Non
Jalons: 3.2 R17

Description

Si on utilise la classe \Dcp\Mail\Message dans une application tierce, c.a.d. autre que depuis CORE ou FDL, alors la version du champs "X-Mailer" contiendra la version de cette application et pas la version de CORE.

Le champs "X-Mailer" indique alors une version de Dynacase Platform qui n'existe pas :

X-Mailer: Dynacase Platform 4.0.1-0.20160609.105652

Il faut que la classe \Dcp\Mail\Message positionne le "X-Mailer" avec la version de dynacase-core et pas la version de l'application tierce qui l'utilise.

Historique

#1 Mis à jour par Marc Claverie il y a presque 3 ans

  • Version cible mis à 3.2.23

#2 Mis à jour par Éric Brison il y a presque 3 ans

  • Assigné à mis à Jérôme Augé
  • Statut changé de Nouveau à Assigné

#3 Mis à jour par Jérôme Augé il y a presque 3 ans

  • % réalisé changé de 0 à 100

#4 Mis à jour par Éric Brison il y a presque 3 ans

  • Statut changé de Assigné à Intégré

Appliqué par commit internal-platfrom:commit:ac763a3d2ba464bab9349d1049d0a3bf69df2271.

Formats disponibles : Atom PDF