Projet

Général

Profil

Amélioration #2771

Afficher les erreurs de pré-requis checkInitServer() avec « style »

Ajouté par Jérôme Augé il y a plus de 8 ans. Mis à jour il y a plus de 8 ans.

Statut:
Nouveau
Priorité:
Normal
Assigné à:
-
Catégorie:
-
Version cible:
-
Début:
29/06/2012
Echéance:
% réalisé:

0%

Temps estimé:
Version source:
Solution proposée:
Principaux fichiers impactés:
Wiki Détail:
Contrôle:
Jalons:

Description

Lorsque les pré-requis pour le fonctionnement de dynacase-control ne sont pas corrects, des messages d'erreurs sont affichés de manière « brute » :

PHP class 'ZipArchive' not found.
PHP function 'json_encode' not found (extension 'json').
…

On pourrait afficher ça de manière plus compréhensible, par exemple :

Prerequisite errors
-------------------

Some elements required by dynacase-control could not be found.

Please check that the following elements are properly installed and/or configured.

• This software requires the 'zip' PHP extention.
• This software requires the 'json' PHP extension.
• …

Historique

#1 Mis à jour par Jérôme Augé il y a plus de 8 ans

  • Sujet changé de Afficher les erreurs de pré-requis avec « style » à Afficher les erreurs de pré-requis checkInitServer() avec « style »

#2 Mis à jour par Jérôme Augé il y a plus de 8 ans

  • Description mis à jour (diff)

Formats disponibles : Atom PDF